We observe the issue - what appears to be a local congestion on router ffm-b23-link.ip.twelve99.net as resolved.
Posted Apr 24, 2026 - 08:06 UTC
Identified
We're observing high latency on Arelion FRA on the ingress path. The upstream has been temporary disabled on ingress, traffic rerouted onto other upstreams.
Posted Apr 24, 2026 - 07:53 UTC
This incident affected: Network Infrastructure (Upstream Carrier).