HEL - High Latency

Incident Report for aurologic GmbH

Resolved

The same has been resolved upon supplier confirmation.
Posted Jul 05, 2026 - 16:49 UTC

Monitoring

At 18:12 CEST, we observed high latency in HEL (Helsinki). The same was related to a suspected backbone issue at Arelion. Traffic rerouted and we see the same stabilizing at 18:25 CEST. A trouble ticket with the supplier has been opened.
Posted Jul 05, 2026 - 16:32 UTC
This incident affected: Network Infrastructure (Upstream Carrier).